Back to overview
Downtime

Known issue affecting login to Nord Account

Jan 30 at 05:27pm EET
Affected services
my.nordaccount.com
Nord Account Authentication

Resolved
Jan 30 at 09:40pm EET

The issue is fixed and all services are operational.

Updated
Jan 30 at 09:10pm EET

A fix has been implemented and service is gradually being restored; a small fraction of users may still be experiencing issues.

Updated
Jan 30 at 08:28pm EET

The issue has resurfaced and our team is actively working to restore Nord Account login functionality.

Updated
Jan 30 at 06:08pm EET

Fix is implement and we do not observe any issues.

Updated
Jan 30 at 05:56pm EET

Our team has identified the root cause of the login issue and is now actively implementing a fix.

Created
Jan 30 at 05:27pm EET

The team is working on resolving the problem affecting user login flow.