Back to overview
NordAccount is experiencing issues
Jan 16 at 11:25am EET
Affected services
my.nordaccount.com
Resolved
Jan 16 at 11:25am EET
Users located in EU are unable to log into their NordAccount
Affected services
Resolved
Jan 16 at 11:25am EET
Users located in EU are unable to log into their NordAccount
Affected services